Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Lua is a powerful light-weight programming language designed \ |
| 2 | for extending applications." |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://doc/readme.html;beginline=307;endline=330;md5=79c3f6b19ad05efe24c1681f025026bb" |
| 5 | HOMEPAGE = "http://www.lua.org/" |
| 6 | |
| 7 | SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz;name=tarballsrc \ |
| 8 | file://lua.pc.in \ |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 9 | file://CVE-2022-28805.patch \ |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 10 | file://CVE-2022-33099.patch \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 11 | ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'http://www.lua.org/tests/lua-${PV_testsuites}-tests.tar.gz;name=tarballtest file://run-ptest ', '', d)} \ |
| 12 | " |
| 13 | |
| 14 | # if no test suite matches PV release of Lua exactly, download the suite for the closest Lua release. |
| 15 | PV_testsuites = "5.4.4" |
| 16 | |
| 17 | SRC_URI[tarballsrc.sha256sum] = "164c7849653b80ae67bec4b7473b884bf5cc8d2dca05653475ec2ed27b9ebf61" |
| 18 | SRC_URI[tarballtest.sha256sum] = "04d28355cd67a2299dfe5708b55a0ff221ccb1a3907a3113cc103ccc05ac6aad" |
| 19 | |
| 20 | inherit pkgconfig binconfig ptest |
| 21 | |
| 22 | PACKAGECONFIG ??= "readline" |
| 23 | PACKAGECONFIG[readline] = ",,readline" |
| 24 | |
| 25 | TARGET_CC_ARCH += " -fPIC ${LDFLAGS}" |
| 26 | EXTRA_OEMAKE = "'CC=${CC} -fPIC' 'MYCFLAGS=${CFLAGS} -fPIC' MYLDFLAGS='${LDFLAGS}' 'AR=ar rcD' 'RANLIB=ranlib -D'" |
| 27 | |
| 28 | do_configure:prepend() { |
| 29 | sed -i -e s:/usr/local:${prefix}:g src/luaconf.h |
| 30 | sed -i -e s:lib/lua/:${baselib}/lua/:g src/luaconf.h |
| 31 | } |
| 32 | |
| 33 | do_compile () { |
| 34 | oe_runmake ${@bb.utils.contains('PACKAGECONFIG', 'readline', 'linux-readline', 'linux', d)} |
| 35 | } |
| 36 | |
| 37 | do_install () { |
| 38 | oe_runmake \ |
| 39 | 'INSTALL_TOP=${D}${prefix}' \ |
| 40 | 'INSTALL_BIN=${D}${bindir}' \ |
| 41 | 'INSTALL_INC=${D}${includedir}/' \ |
| 42 | 'INSTALL_MAN=${D}${mandir}/man1' \ |
| 43 | 'INSTALL_SHARE=${D}${datadir}/lua' \ |
| 44 | 'INSTALL_LIB=${D}${libdir}' \ |
| 45 | 'INSTALL_CMOD=${D}${libdir}/lua/5.4' \ |
| 46 | install |
| 47 | install -d ${D}${libdir}/pkgconfig |
| 48 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 49 | sed -e s/@VERSION@/${PV}/ -e s#@LIBDIR@#${libdir}# -e s#@INCLUDEDIR@#${includedir}# ${WORKDIR}/lua.pc.in > ${WORKDIR}/lua.pc |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 50 | install -m 0644 ${WORKDIR}/lua.pc ${D}${libdir}/pkgconfig/ |
| 51 | rmdir ${D}${datadir}/lua/5.4 |
| 52 | rmdir ${D}${datadir}/lua |
| 53 | } |
| 54 | |
| 55 | do_install_ptest () { |
| 56 | cp -R --no-dereference --preserve=mode,links -v ${WORKDIR}/lua-${PV_testsuites}-tests ${D}${PTEST_PATH}/test |
| 57 | } |
| 58 | |
| 59 | BBCLASSEXTEND = "native nativesdk" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 60 | |
| 61 | inherit multilib_script |
| 62 | MULTILIB_SCRIPTS = "${PN}-dev:${includedir}/luaconf.h" |