Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Library and tool for installing Python wheels" |
| 2 | DESCRIPTION = "A low-level library for installing a Python package from a wheel distribution." |
| 3 | HOMEPAGE = "https://installer.readthedocs.io/" |
| 4 | BUGTRACKER = "https://github.com/pypa/installer/issues" |
| 5 | |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5038641aec7a77451e31da828ebfae00" |
| 8 | |
| 9 | SRC_URI += "file://interpreter.patch" |
| 10 | |
| 11 | SRC_URI[sha256sum] = "f3bd36cd261b440a88a1190b1becca0578fee90b4b62decc796932fdd5ae8839" |
| 12 | |
| 13 | inherit pypi python_flit_core |
| 14 | |
| 15 | # Bootstrap the native build |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 16 | DEPENDS:remove:class-native = "python3-build-native python3-installer-native" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 17 | |
| 18 | INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode" |
| 19 | |
| 20 | do_compile:class-native () { |
| 21 | python_flit_core_do_manual_build |
| 22 | } |
| 23 | |
| 24 | do_install:prepend:class-native() { |
| 25 | export PYTHONPATH="${S}/src" |
| 26 | } |
| 27 | |
| 28 | BBCLASSEXTEND = "native nativesdk" |