Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions" |
| 2 | DESCRIPTION = "\ |
| 3 | Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \ |
| 4 | intentions. And before you ask: It’s BSD licensed!" |
| 5 | HOMEPAGE = "https://github.com/mitsuhiko/flask/" |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75" |
| 8 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "7eb373984bf1c770023fce9db164ed0c3353cd0b53f130f4693da0ca756a2e6d" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 10 | |
| 11 | PYPI_PACKAGE = "Flask" |
| 12 | |
| 13 | inherit pypi setuptools3 |
| 14 | |
| 15 | CLEANBROKEN = "1" |
| 16 | |
| 17 | RDEPENDS:${PN} = " \ |
| 18 | ${PYTHON_PN}-werkzeug \ |
| 19 | ${PYTHON_PN}-jinja2 \ |
| 20 | ${PYTHON_PN}-itsdangerous \ |
| 21 | ${PYTHON_PN}-click \ |
| 22 | ${PYTHON_PN}-profile \ |
| 23 | " |