Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Simplified object serialization in python" |
| 2 | DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converting complex datatypes, such as objects, to and from native Python datatypes." |
| 3 | AUTHOR = "Marius Kriegerowski <mk@quakesaver.net>" |
| 4 | HOMEPAGE = "https://github.com/marshmallow-code/marshmallow" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "\ |
| 7 | file://LICENSE;md5=5bccd400dedfa74364481e56aacc0b4a \ |
| 8 | file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb" |
| 9 | |
| 10 | SRC_URI = "git://github.com/marshmallow-code/marshmallow.git;protocol=https;branch=dev" |
| 11 | |
| 12 | SRCREV = "78edf5582ee325bba99f097cb7167ef73b6f84d8" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit setuptools3 |
| 17 | |
| 18 | PIP_INSTALL_PACKAGE = "marshmallow" |
| 19 | |
| 20 | RDEPENDS:${PN} += " \ |
| 21 | python3-core \ |
| 22 | python3-datetime \ |
| 23 | python3-netclient \ |
| 24 | python3-numbers \ |
| 25 | python3-json \ |
| 26 | python3-pprint \ |
| 27 | python3-packaging \ |
| 28 | " |