Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "matplotlib: plotting with Python" |
| 2 | DESCRIPTION = "\ |
| 3 | Matplotlib is a Python 2D plotting library which produces \ |
| 4 | publication-quality figures in a variety of hardcopy formats \ |
| 5 | and interactive environments across platforms." |
| 6 | HOMEPAGE = "https://github.com/matplotlib/matplotlib" |
| 7 | SECTION = "devel/python" |
| 8 | LICENSE = "PSF-2.0" |
| 9 | LIC_FILES_CHKSUM = "\ |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 10 | file://setup.py;beginline=283;endline=283;md5=20e7ab4d2b2b1395a0e4ab800181eb96 \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 11 | file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \ |
| 12 | " |
| 13 | |
| 14 | DEPENDS = "\ |
| 15 | freetype \ |
| 16 | libpng \ |
| 17 | python3-numpy-native \ |
| 18 | python3-pip-native \ |
| 19 | python3-dateutil-native \ |
| 20 | python3-pytz-native \ |
| 21 | python3-certifi-native \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 22 | python3-setuptools-scm-native \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 23 | " |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 24 | SRC_URI[sha256sum] = "1f4d69707b1677560cd952544ee4962f68ff07952fb9069ff8c12b56353cb8c9" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 25 | |
| 26 | inherit pypi setuptools3 pkgconfig |
| 27 | |
| 28 | # Stop the component from attempting to download when it detects a missing |
| 29 | # dependency |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 30 | SRC_URI += "file://matplotlib-disable-download.patch \ |
| 31 | file://0001-removed-RandomNumberGenerator-class-included-random-.patch" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 32 | |
| 33 | # This python module requires a full copy of freetype-2.6.1 |
| 34 | SRC_URI += "https://downloads.sourceforge.net/project/freetype/freetype2/2.6.1/freetype-2.6.1.tar.gz;name=freetype;subdir=matplotlib-${PV}/build" |
| 35 | SRC_URI[freetype.sha256sum] = "0a3c7dfbda6da1e8fce29232e8e96d987ababbbf71ebc8c75659e4132c367014" |
| 36 | |
| 37 | # This python module requires a full copy of 'qhull-2020' |
| 38 | SRC_URI += "http://www.qhull.org/download/qhull-2020-src-8.0.2.tgz;name=qhull;subdir=matplotlib-${PV}/build" |
| 39 | SRC_URI[qhull.sha256sum] = "b5c2d7eb833278881b952c8a52d20179eab87766b00b865000469a45c1838b7e" |
| 40 | |
| 41 | # LTO with clang needs lld |
| 42 | LDFLAGS:append:toolchain-clang = " -fuse-ld=lld" |
| 43 | LDFLAGS:remove:toolchain-clang:mips = "-fuse-ld=lld" |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 44 | LDFLAGS:remove:toolchain-clang:riscv64 = "-fuse-ld=lld" |
| 45 | LDFLAGS:remove:toolchain-clang:riscv32 = "-fuse-ld=lld" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 46 | RDEPENDS:${PN} = "\ |
| 47 | freetype \ |
| 48 | libpng \ |
| 49 | python3-numpy \ |
| 50 | python3-pyparsing \ |
| 51 | python3-cycler \ |
| 52 | python3-dateutil \ |
| 53 | python3-kiwisolver \ |
| 54 | python3-pytz \ |
| 55 | python3-pillow \ |
| 56 | python3-packaging \ |
| 57 | " |
| 58 | |
| 59 | ENABLELTO:toolchain-clang:riscv64 = "echo enable_lto = False >> ${S}/mplsetup.cfg" |
| 60 | ENABLELTO:toolchain-clang:riscv32 = "echo enable_lto = False >> ${S}/mplsetup.cfg" |
| 61 | ENABLELTO:toolchain-clang:mips = "echo enable_lto = False >> ${S}/mplsetup.cfg" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 62 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 63 | do_compile:prepend() { |
| 64 | echo [libs] > ${S}/mplsetup.cfg |
| 65 | echo system_freetype = True >> ${S}/mplsetup.cfg |
| 66 | ${ENABLELTO} |
| 67 | } |
| 68 | |
| 69 | BBCLASSEXTEND = "native" |