Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "High-level GnuPG encryption/signing API" |
| 2 | DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management" |
| 3 | HOMEPAGE = "http://www.gnupg.org/gpgme.html" |
| 4 | BUGTRACKER = "https://bugs.g10code.com/gnupg/index" |
| 5 | |
| 6 | LICENSE = "GPLv2+ & LGPLv2.1+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 8 | file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \ |
| 9 | file://src/gpgme.h.in;endline=23;md5=2f0bf06d1c7dcb28532a9d0f94a7ca1d \ |
| 10 | file://src/engine.h;endline=22;md5=4b6d8ba313d9b564cc4d4cfb1640af9d" |
| 11 | |
| 12 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" |
| 13 | SRC_URI = "${GNUPG_MIRROR}/gpgme/${BP}.tar.bz2 \ |
| 14 | file://0001-Revert-build-Make-gpgme.m4-use-gpgrt-config-with-.pc.patch \ |
| 15 | file://0001-pkgconfig.patch \ |
| 16 | file://0002-gpgme-lang-python-gpg-error-config-should-not-be-use.patch \ |
| 17 | file://0003-Correctly-install-python-modules.patch \ |
| 18 | file://0004-python-import.patch \ |
| 19 | file://0005-gpgme-config-skip-all-lib-or-usr-lib-directories-in-.patch \ |
| 20 | file://0006-fix-build-path-issue.patch \ |
| 21 | file://0007-python-Add-variables-to-tests.patch \ |
| 22 | file://0008-do-not-auto-check-var-PYTHON.patch \ |
| 23 | " |
| 24 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 25 | SRC_URI[md5sum] = "198f0a908ec3cd8f0ce9a4f3a4489645" |
| 26 | SRC_URI[sha256sum] = "c4e30b227682374c23cddc7fdb9324a99694d907e79242a25a4deeedb393be46" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 27 | |
| 28 | DEPENDS = "libgpg-error libassuan" |
| 29 | RDEPENDS_${PN}-cpp += "libstdc++" |
| 30 | |
| 31 | RDEPENDS_python2-gpg += "python-unixadmin" |
| 32 | RDEPENDS_python3-gpg += "python3-unixadmin" |
| 33 | |
| 34 | BINCONFIG = "${bindir}/gpgme-config" |
| 35 | |
| 36 | # Note select python2 or python3, but you can't select both at the same time |
| 37 | PACKAGECONFIG ??= "python3" |
| 38 | PACKAGECONFIG[python2] = ",,python swig-native," |
| 39 | PACKAGECONFIG[python3] = ",,python3 swig-native," |
| 40 | |
| 41 | # Default in configure.ac: "cl cpp python qt" |
| 42 | # Supported: "cl cpp python python2 python3 qt" |
| 43 | # python says 'search and find python2 or python3' |
| 44 | |
| 45 | # Building the C++ bindings for native requires a C++ compiler with C++11 |
| 46 | # support. Since these bindings are currently not needed, we can disable them. |
| 47 | DEFAULT_LANGUAGES = "" |
| 48 | DEFAULT_LANGUAGES_class-target = "cpp" |
| 49 | LANGUAGES ?= "${DEFAULT_LANGUAGES} python" |
| 50 | |
| 51 | PYTHON_INHERIT = "${@bb.utils.contains('PACKAGECONFIG', 'python2', 'pythonnative', '', d)}" |
| 52 | PYTHON_INHERIT .= "${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native', '', d)}" |
| 53 | |
| 54 | EXTRA_OECONF += '--enable-languages="${LANGUAGES}" \ |
| 55 | --disable-gpgconf-test \ |
| 56 | --disable-gpg-test \ |
| 57 | --disable-gpgsm-test \ |
| 58 | --disable-g13-test \ |
| 59 | --disable-lang-python-test \ |
| 60 | ' |
| 61 | |
| 62 | inherit autotools texinfo binconfig-disabled pkgconfig distutils-common-base ${PYTHON_INHERIT} |
| 63 | |
| 64 | export PKG_CONFIG='pkg-config' |
| 65 | |
| 66 | BBCLASSEXTEND = "native nativesdk" |
| 67 | |
| 68 | PACKAGES =+ "${PN}-cpp" |
| 69 | PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'python2', 'python2-gpg ', '', d)}" |
| 70 | PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3-gpg ', '', d)}" |
| 71 | |
| 72 | FILES_${PN}-cpp = "${libdir}/libgpgmepp.so.*" |
| 73 | FILES_python2-gpg = "${PYTHON_SITEPACKAGES_DIR}/*" |
| 74 | FILES_python3-gpg = "${PYTHON_SITEPACKAGES_DIR}/*" |
| 75 | FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/* \ |
| 76 | ${libdir}/cmake/* \ |
| 77 | " |
| 78 | |
| 79 | CFLAGS_append_libc-musl = " -D__error_t_defined " |
| 80 | do_configure_prepend () { |
| 81 | # Else these could be used in preference to those in aclocal-copy |
| 82 | rm -f ${S}/m4/gpg-error.m4 |
| 83 | rm -f ${S}/m4/libassuan.m4 |
| 84 | rm -f ${S}/m4/python.m4 |
| 85 | } |