Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 1 | # Copyright (C) 2015 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Glibc hierarchical argument parsing standalone library" |
| 5 | DESCRIPTION = "Standalone version of arguments parsing functions from GLIBC" |
| 6 | HOMEPAGE = "https://github.com/ericonr/argp-standalone" |
| 7 | LICENSE = "LGPL-2.1-only" |
| 8 | LIC_FILES_CHKSUM = "file://argp.h;beginline=1;endline=20;md5=464f2cfb1c35a5123f9e309d7afd79f8" |
| 9 | SECTION = "libs" |
| 10 | |
| 11 | SRC_URI = "git://github.com/ericonr/argp-standalone;branch=master;protocol=https \ |
| 12 | file://out_of_tree_build.patch \ |
| 13 | " |
| 14 | SRCREV = "e5fe9ad9e83e6765cf8fa787f903d4c6792338b5" |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit autotools |
| 18 | |
| 19 | CFLAGS += "-fPIC -U__OPTIMIZE__" |
| 20 | |
| 21 | DEV_PKG_DEPENDENCY = "" |
| 22 | RDEPENDS:${PN}-staticdev = "" |
| 23 | |
| 24 | do_install() { |
| 25 | install -D -m 0644 ${B}/libargp.a ${D}${libdir}/libargp.a |
| 26 | install -D -m 0644 ${S}/argp.h ${D}${includedir}/argp.h |
| 27 | } |
| 28 | # |
| 29 | # We will skip parsing for non-musl systems |
| 30 | # |
| 31 | COMPATIBLE_HOST = ".*-musl.*" |