Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | require rsync.inc |
| 2 | |
| 3 | SRC_URI += "file://makefile-no-rebuild.patch" |
| 4 | |
| 5 | SRC_URI[md5sum] = "1581a588fde9d89f6bc6201e8129afaf" |
| 6 | SRC_URI[sha256sum] = "55cc554efec5fdaad70de921cd5a5eeb6c29a95524c715f3bbf849235b0800c0" |
| 7 | |
| 8 | # GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0) |
| 9 | LICENSE = "GPLv3+" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 11 | |
| 12 | PACKAGECONFIG ??= "acl attr \ |
| 13 | ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \ |
| 14 | " |
| 15 | PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl," |
| 16 | PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr," |
| 17 | |
| 18 | # By default, if crosscompiling, rsync disables a number of |
| 19 | # capabilities, hardlinking symlinks and special files (i.e. devices) |
| 20 | CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes" |
| 21 | |
| 22 | # rsync 3.0 uses configure.sh instead of configure, and |
| 23 | # makefile checks the existence of configure.sh |
| 24 | do_configure_prepend () { |
| 25 | rm -f ${S}/configure ${S}/configure.sh |
| 26 | } |
| 27 | |
| 28 | do_configure_append () { |
| 29 | cp -f ${S}/configure ${S}/configure.sh |
| 30 | } |
| 31 | |
| 32 | BBCLASSEXTEND = "native" |