Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "3D graphics and compute API common loader" |
| 2 | DESCRIPTION = "Vulkan is a new generation graphics and compute API \ |
| 3 | that provides efficient access to modern GPUs. These packages \ |
| 4 | provide only the common vendor-agnostic library loader, headers and \ |
| 5 | the vulkaninfo utility." |
| 6 | HOMEPAGE = "https://www.khronos.org/vulkan/" |
| 7 | BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Loader" |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | LICENSE = "Apache-2.0" |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7dbefed23242760aa3475ee42801c5ac" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 12 | SRC_URI = "git://github.com/KhronosGroup/Vulkan-Loader.git \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 13 | " |
Andrew Geissler | 5f35090 | 2021-07-23 13:09:54 -0400 | [diff] [blame] | 14 | SRCREV = "1896143df69d439b0933c1bb485f5a4587bdf2dc" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | REQUIRED_DISTRO_FEATURES = "vulkan" |
| 19 | |
| 20 | inherit cmake features_check |
| 21 | ANY_OF_DISTRO_FEATURES = "x11 wayland" |
| 22 | |
| 23 | DEPENDS += "vulkan-headers" |
| 24 | |
| 25 | EXTRA_OECMAKE = "\ |
| 26 | -DBUILD_TESTS=OFF \ |
| 27 | -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \ |
| 28 | -DASSEMBLER_WORKS=FALSE \ |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 29 | -DVulkanHeaders_INCLUDE_DIR=${STAGING_INCDIR} \ |
| 30 | -DVulkanRegistry_DIR=${RECIPE_SYSROOT}/${datadir} \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 31 | " |
| 32 | |
| 33 | # must choose x11 or wayland or both |
| 34 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}" |
| 35 | |
| 36 | PACKAGECONFIG[x11] = "-DBUILD_WSI_XLIB_SUPPORT=ON -DBUILD_WSI_XCB_SUPPORT=ON, -DBUILD_WSI_XLIB_SUPPORT=OFF -DBUILD_WSI_XCB_SUPPORT=OFF, libxcb libx11 libxrandr" |
| 37 | PACKAGECONFIG[wayland] = "-DBUILD_WSI_WAYLAND_SUPPORT=ON, -DBUILD_WSI_WAYLAND_SUPPORT=OFF, wayland" |
| 38 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | RRECOMMENDS:${PN} = "mesa-vulkan-drivers" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 40 | |
| 41 | UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)" |