Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Helper tool used when compiling" |
| 2 | DESCRIPTION = "pkg-config is a helper tool used when compiling applications and libraries. It helps determined \ |
| 3 | the correct compiler/link options. It is also language-agnostic." |
| 4 | HOMEPAGE = "http://pkg-config.freedesktop.org/wiki/" |
| 5 | BUGTRACKER = "http://bugs.freedesktop.org/buglist.cgi?product=pkg-config" |
| 6 | SECTION = "console/utils" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 7 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 8 | LICENSE = "GPL-2.0-or-later" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 10 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 11 | SRCREV = "d97db4fae4c1cd099b506970b285dc2afd818ea2" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 12 | PV = "0.29.2+git${SRCPV}" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 13 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 14 | SRC_URI = "git://gitlab.freedesktop.org/pkg-config/pkg-config.git;branch=master;protocol=https \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 15 | file://pkg-config-esdk.in \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 16 | file://pkg-config-native.in \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 17 | file://0001-glib-gettext.m4-Update-AM_GLIB_GNU_GETTEXT-to-match-.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | " |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | inherit autotools |
| 23 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 24 | # Because of a faulty test, the current auto mode always evaluates to no, |
| 25 | # so just continue that behaviour. |
| 26 | # |
| 27 | EXTRA_OECONF += "--disable-indirect-deps" |
| 28 | |
| 29 | PACKAGECONFIG ??= "glib" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | PACKAGECONFIG:class-native = "" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 31 | |
| 32 | PACKAGECONFIG[glib] = "--without-internal-glib,--with-internal-glib,glib-2.0 pkgconfig-native" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 33 | |
| 34 | acpaths = "-I ." |
| 35 | |
| 36 | BBCLASSEXTEND = "native nativesdk" |
| 37 | |
| 38 | # Set an empty dev package to ensure the base PN package gets |
| 39 | # the pkg.m4 macros, pkgconfig does not deliver any other -dev |
| 40 | # files. |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 41 | FILES:${PN}-dev = "" |
| 42 | FILES:${PN} += "${datadir}/aclocal/pkg.m4" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 43 | |
| 44 | # When using the RPM generated automatic package dependencies, some packages |
| 45 | # will end up requiring 'pkgconfig(pkg-config)'. Allow this behavior by |
| 46 | # specifying an appropriate provide. |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 47 | RPROVIDES:${PN} += "pkgconfig(pkg-config)" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 48 | |
| 49 | # Install a pkg-config-native wrapper that will use the native sysroot instead |
| 50 | # of the MACHINE sysroot, for using pkg-config when building native tools. |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 51 | do_install:append:class-native () { |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 52 | sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \ |
| 53 | -e "s|@LIBDIR_NATIVE@|${PKG_CONFIG_LIBDIR}|" \ |
| 54 | < ${WORKDIR}/pkg-config-native.in > ${B}/pkg-config-native |
| 55 | install -m755 ${B}/pkg-config-native ${D}${bindir}/pkg-config-native |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 56 | sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \ |
| 57 | -e "s|@LIBDIR_NATIVE@|${PKG_CONFIG_LIBDIR}|" \ |
| 58 | < ${WORKDIR}/pkg-config-esdk.in > ${B}/pkg-config-esdk |
| 59 | install -m755 ${B}/pkg-config-esdk ${D}${bindir}/pkg-config-esdk |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 60 | } |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 61 | |
| 62 | pkgconfig_sstate_fixup_esdk () { |
| 63 | if [ "${BB_CURRENTTASK}" = "populate_sysroot_setscene" -a "${WITHIN_EXT_SDK}" = "1" ] ; then |
| 64 | pkgconfdir="${SSTATE_INSTDIR}/recipe-sysroot-native/${bindir_native}" |
| 65 | mv $pkgconfdir/pkg-config $pkgconfdir/pkg-config.real |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 66 | ln -rs $pkgconfdir/pkg-config-esdk $pkgconfdir/pkg-config |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 67 | sed -i -e "s|^pkg-config|pkg-config.real|" $pkgconfdir/pkg-config-native |
| 68 | fi |
| 69 | } |
| 70 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 71 | SSTATEPOSTUNPACKFUNCS:append:class-native = " pkgconfig_sstate_fixup_esdk" |