Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | uboot_prep_kimage() { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 2 | if [ -e arch/${ARCH}/boot/compressed/vmlinux ]; then |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 3 | vmlinux_path="arch/${ARCH}/boot/compressed/vmlinux" |
| 4 | linux_suffix="" |
| 5 | linux_comp="none" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 6 | elif [ -e arch/${ARCH}/boot/vmlinuz.bin ]; then |
| 7 | rm -f linux.bin |
| 8 | cp -l arch/${ARCH}/boot/vmlinuz.bin linux.bin |
| 9 | vmlinux_path="" |
| 10 | linux_suffix="" |
| 11 | linux_comp="none" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 12 | else |
| 13 | vmlinux_path="vmlinux" |
| 14 | linux_suffix=".gz" |
| 15 | linux_comp="gzip" |
| 16 | fi |
| 17 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 18 | [ -n "${vmlinux_path}" ] && ${OBJCOPY} -O binary -R .note -R .comment -S "${vmlinux_path}" linux.bin |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 19 | |
| 20 | if [ "${linux_comp}" != "none" ] ; then |
| 21 | gzip -9 linux.bin |
| 22 | mv -f "linux.bin${linux_suffix}" linux.bin |
| 23 | fi |
| 24 | |
| 25 | echo "${linux_comp}" |
| 26 | } |