Andrew Geissler | e231d58 | 2020-05-05 08:53:09 -0500 | [diff] [blame] | 1 | SUMMARY = "A partition editor to graphically manage disk partitions " |
| 2 | HOMEPAGE = "http://gparted.org/index.php" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 5 | |
| 6 | inherit features_check autotools pkgconfig python3native gnome-help gtk-icon-cache |
| 7 | |
| 8 | REQUIRED_DISTRO_FEATURES = "x11" |
| 9 | |
| 10 | SRC_URI = " \ |
| 11 | ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.gz \ |
| 12 | file://0001-Install-polkit-action-unconditionally-executable-pke.patch \ |
| 13 | " |
| 14 | SRC_URI[md5sum] = "0da45cb522d766dfb4886fb3bdbc2634" |
| 15 | SRC_URI[sha256sum] = "e2fe7b7afbc07e930491c00a05200c2682cc0576ca8f6da87245a000257f5924" |
| 16 | |
| 17 | DEPENDS += " \ |
| 18 | glib-2.0-native \ |
| 19 | yelp-tools-native \ |
| 20 | intltool-native \ |
| 21 | glib-2.0 \ |
| 22 | gtkmm3 \ |
| 23 | parted \ |
| 24 | " |
| 25 | |
| 26 | FILES_${PN} += " \ |
| 27 | ${datadir}/appdata \ |
| 28 | ${datadir}/icons \ |
| 29 | " |
| 30 | |
| 31 | PACKAGES += "${PN}-polkit" |
| 32 | FILES_${PN}-polkit = "${datadir}/polkit-1" |
| 33 | |
| 34 | RDEPENDS_${PN} = " \ |
| 35 | ${@bb.utils.contains('DISTRO_FEATURES', 'polkit', '${PN}-polkit', '', d)} \ |
| 36 | dosfstools \ |
| 37 | mtools \ |
| 38 | e2fsprogs \ |
| 39 | " |