blob: a94356f19e02cbc27fe5522932771d60b49f8764 [file] [log] [blame]
Supreeth Venkateshd1b931c2020-05-27 15:16:15 -05001FILESEXTRAPATHS_append := "${THISDIR}/files:"
2
3inherit obmc-phosphor-systemd
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=ab6ba4709f1286c534f36392ac1dcd27"
6
7S = "${WORKDIR}/"
8
9SRC_URI = "file://setup_gpio.sh \
10 file://power-util \
11 file://host-gpio.service \
12 file://host-poweroff.service \
13 file://host-poweron.service \
14 file://LICENSE"
15
16DEPENDS = "systemd"
17RDEPENDS_${PN} = "bash"
18
19SYSTEMD_PACKAGES = "${PN}"
20SYSTEMD_SERVICE_${PN} = "host-gpio.service host-poweron.service host-poweroff.service"
21
22do_install() {
23 install -d ${D}/usr/sbin
24 install -m 0755 ${S}setup_gpio.sh ${D}/${sbindir}/
25 install -m 0755 ${S}power-util ${D}/${sbindir}/
26}