| FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
| |
| DEPS_CFG = "resetreason.conf" |
| DEPS_TGT = "phosphor-discover-system-state@.service" |
| SYSTEMD_OVERRIDE_${PN}-discover_append = "${DEPS_CFG}:${DEPS_TGT}.d/${DEPS_CFG}" |
| |
| # We don't want the obmc-host-shutdown (softoff) to require |
| # obmc-chassis-poweroff. obmc-chassis-poweroff will be activated once |
| # the Shutdown ACK pin is toggled (monitored by phosphor-gpio-monitor) |
| HOST_STOP_FMT = "" |
| HOST_REBOOT_FMT = "" |
| |
| pkg_postinst_${PN}-obmc-targets_append() { |
| rm "$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/obmc-chassis-poweroff@0.target" |
| |
| rm "$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service" |
| rm "$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/obmc-host-force-warm-reboot@0.target" |
| |
| rm "$D$systemd_system_unitdir/obmc-host-reboot@0.target.requires/phosphor-reboot-host@0.service" |
| rm "$D$systemd_system_unitdir/obmc-host-reboot@0.target.requires/obmc-host-shutdown@0.target" |
| |
| rm "$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/obmc-host-stop@0.target" |
| rm "$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/phosphor-reboot-host@0.service" |
| } |