blob: f683f80158c3ab5ba886a5f344cd852bc9d02451 [file] [log] [blame]
Thang Q. Nguyen458c1f92020-12-24 02:22:46 +00001SUMMARY = "Ampere Computing LLC Add Ethernet over USB gadget device"
2DESCRIPTION = "Add Ethernet over USB gadget device for Ampere systems"
3PR = "r1"
4
5LICENSE = "Apache-2.0"
6S = "${WORKDIR}"
7
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
9
10inherit systemd
11inherit obmc-phosphor-systemd
12
13DEPENDS = "systemd"
14RDEPENDS_${PN} = "bash"
15
16SYSTEMD_PACKAGES = "${PN}"
17SYSTEMD_SERVICE_${PN} = " \
18 ampere_add_usbnet_gadget.service \
19 "
20
21SRC_URI += "file://00-bmc-usb0.network"
22SRC_URI += "file://ampere_add_usbnet_gadget.sh"
23
24do_install_append() {
25 install -d ${D}${sbindir}
26 install -d ${D}/etc/systemd/network
27 install -m 744 ${WORKDIR}/ampere_add_usbnet_gadget.sh ${D}${sbindir}/
28 install -m 644 ${WORKDIR}/00-bmc-usb0.network \
29 ${D}/etc/systemd/network/
30}