blob: a93ad5757ea3bbdc8fef9eca2311a72bab642774 [file] [log] [blame]
Patrick Venture0d9aa692018-09-17 17:14:46 -07001SUMMARY = "Google Sys OEM commands"
Patrick Venturef52dcab2018-09-21 14:57:58 -07002DESCRIPTION = "Google Sys OEM commands"
Patrick Ventureb3fc8392018-09-26 08:42:56 -07003HOMEPAGE = "https://github.com/openbmc/google-ipmi-sys"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture0d9aa692018-09-17 17:14:46 -07008
9inherit autotools pkgconfig
Patrick Venture0d9aa692018-09-17 17:14:46 -070010inherit systemd
11inherit obmc-phosphor-ipmiprovider-symlink
12
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "sdbusplus"
15DEPENDS += "phosphor-logging"
Patrick Venture0d9aa692018-09-17 17:14:46 -070016DEPENDS += "phosphor-ipmi-host"
17
Patrick Venture0d9aa692018-09-17 17:14:46 -070018S = "${WORKDIR}/git"
19SRC_URI = "git://github.com/openbmc/google-ipmi-sys"
Andrew Geissler2c99bf42018-11-26 17:20:08 +000020SRCREV = "23ef59b7b545f70976e9901b2b1a1962d73b8484"
Patrick Venture0d9aa692018-09-17 17:14:46 -070021
22FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
23FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
24FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
25FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
26
27HOSTIPMI_PROVIDER_LIBRARY += "libsyscmds.so"
28
29SYSTEMD_PACKAGES = "${PN}"
30SYSTEMD_SERVICE_${PN} = "gbmc-psu-hardreset.target"
31
32do_install_append() {
33 install -d ${D}${systemd_system_unitdir}
34 install -m 0644 ${S}/gbmc-psu-hardreset.target ${D}${systemd_system_unitdir}
35}