Patrick Venture | 0d9aa69 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 1 | SUMMARY = "Google Sys OEM commands" |
Patrick Venture | f52dcab | 2018-09-21 14:57:58 -0700 | [diff] [blame] | 2 | DESCRIPTION = "Google Sys OEM commands" |
Patrick Venture | b3fc839 | 2018-09-26 08:42:56 -0700 | [diff] [blame] | 3 | HOMEPAGE = "https://github.com/openbmc/google-ipmi-sys" |
| 4 | PR = "r1" |
| 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Patrick Venture | 0d9aa69 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 8 | |
| 9 | inherit autotools pkgconfig |
Patrick Venture | 0d9aa69 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 10 | inherit systemd |
| 11 | inherit obmc-phosphor-ipmiprovider-symlink |
| 12 | |
| 13 | DEPENDS += "autoconf-archive-native" |
| 14 | DEPENDS += "sdbusplus" |
| 15 | DEPENDS += "phosphor-logging" |
Patrick Venture | 0d9aa69 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 16 | DEPENDS += "phosphor-ipmi-host" |
| 17 | |
Patrick Venture | 0d9aa69 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 18 | S = "${WORKDIR}/git" |
| 19 | SRC_URI = "git://github.com/openbmc/google-ipmi-sys" |
Patrick Venture | f52dcab | 2018-09-21 14:57:58 -0700 | [diff] [blame] | 20 | SRCREV = "ef45005c2c441a89a9bd84b9b0f22ac8a2fd9b65" |
Patrick Venture | 0d9aa69 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 21 | |
| 22 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 23 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 24 | FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 25 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
| 26 | |
| 27 | HOSTIPMI_PROVIDER_LIBRARY += "libsyscmds.so" |
| 28 | |
| 29 | SYSTEMD_PACKAGES = "${PN}" |
| 30 | SYSTEMD_SERVICE_${PN} = "gbmc-psu-hardreset.target" |
| 31 | |
| 32 | do_install_append() { |
| 33 | install -d ${D}${systemd_system_unitdir} |
| 34 | install -m 0644 ${S}/gbmc-psu-hardreset.target ${D}${systemd_system_unitdir} |
| 35 | } |