Patrick Venture | 7e55649 | 2018-10-24 11:10:32 -0700 | [diff] [blame] | 1 | SUMMARY = "Google i2c OEM commands" |
| 2 | DESCRIPTION = "Google i2c OEM commands" |
| 3 | HOMEPAGE = "https://github.com/openbmc/google-ipmi-i2c" |
| 4 | PR = "r1" |
| 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 8 | |
| 9 | inherit autotools pkgconfig |
| 10 | inherit obmc-phosphor-ipmiprovider-symlink |
| 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
| 13 | DEPENDS += "phosphor-ipmi-host" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | SRC_URI = "git://github.com/openbmc/google-ipmi-i2c" |
Andrew Geissler | f8d3b5a | 2019-02-12 21:20:27 +0000 | [diff] [blame] | 17 | SRCREV = "d7f368aae016cb2987ee0499b79174cb0ef79f6a" |
Patrick Venture | 7e55649 | 2018-10-24 11:10:32 -0700 | [diff] [blame] | 18 | |
| 19 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 20 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 21 | FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 22 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
| 23 | |
| 24 | HOSTIPMI_PROVIDER_LIBRARY += "libi2ccmds.so" |