Change wants to requires for all critical services

In order for targets to fail when their services fail,
the relationship must be a "requires"

Change-Id: I1523dd51af8817b473557bac65e9e71eacecf52e
Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb b/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb
index 7d577cc..ba745bd 100644
--- a/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb
+++ b/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb
@@ -18,7 +18,7 @@
 TMPL = "vrm-control@.service"
 INSTFMT = "vrm-control@{0}.service"
 TGTFMT = "obmc-power-chassis-on@{0}.target"
-FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
+FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
 
 SYSTEMD_SERVICE_${PN} += "${TMPL}"
 SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"