Monitor fan apps for watchdog protection

This overrides the fan-control and fan-monitor service files
to call the fan-watchdog-monitor service on fails.

The watchdog monitor service will start the obmc-fan-watchdog-takeover
target to expire the fan watchdog when these apps have exceeded
their retry limits.

Note that fan-presence-tach and fan-control-init do not need watchdog
protection because they are in the poweron path and will fail the
poweron if they fail.

Resolves openbmc/openbmc#1688

Change-Id: I807da09f60213104163833114a8240f5fae9053a
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog.bb b/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog.bb
index cebeefd..a74293f 100644
--- a/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog.bb
+++ b/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog.bb
@@ -10,6 +10,8 @@
 TGTFMT = "obmc-chassis-poweron@0.target"
 RESET_FMT = "../${RESET_SERVICE}:${TGTFMT}.requires/${RESET_SERVICE}"
 
-SYSTEMD_SERVICE_${PN} += "${RESET_SERVICE}"
+MONITOR_SERVICE = "witherspoon-fan-watchdog-monitor@.service"
+
+SYSTEMD_SERVICE_${PN} += "${RESET_SERVICE} ${MONITOR_SERVICE}"
 SYSTEMD_LINK_${PN} += "${RESET_FMT}"
 SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/witherspoon-fan-watchdog/witherspoon-reset-fan-watchdog.conf"