blob: a74293ff8ec615d414e1bd03a3b3c001e9a6bab2 [file] [log] [blame]
SUMMARY = "Witherspoon fan watchdog services"
PR = "r1"
inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
RDEPENDS_${PN} += "phosphor-gpio-monitor"
RESET_SERVICE = "witherspoon-reset-fan-watchdog.service"
TGTFMT = "obmc-chassis-poweron@0.target"
RESET_FMT = "../${RESET_SERVICE}:${TGTFMT}.requires/${RESET_SERVICE}"
MONITOR_SERVICE = "witherspoon-fan-watchdog-monitor@.service"
SYSTEMD_SERVICE_${PN} += "${RESET_SERVICE} ${MONITOR_SERVICE}"
SYSTEMD_LINK_${PN} += "${RESET_FMT}"
SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/witherspoon-fan-watchdog/witherspoon-reset-fan-watchdog.conf"