blob: c51084296333e54a7dc2f26c58dda409151bacb3 [file] [log] [blame]
Matt Spinler65ced222019-06-12 10:03:29 -05001SUMMARY = "Power device Workarounds"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
5
6inherit obmc-phosphor-systemd
7
8RDEPENDS_${PN} += "i2c-tools"
9
10S = "${WORKDIR}"
11
12SRC_URI += "file://power-workarounds.sh"
13
14do_install() {
15 install -d ${D}${bindir}
16 install -m 0755 ${S}/power-workarounds.sh ${D}${bindir}/power-workarounds.sh
17}
18
19TMPL_WA = "power-workarounds@.service"
20INSTFMT_WA = "power-workarounds@{0}.service"
21TGTFMT = "obmc-chassis-poweron@{0}.target"
22FMT_WA = "../${TMPL_WA}:${TGTFMT}.requires/${INSTFMT_WA}"
23
24SYSTEMD_SERVICE_${PN} += "${TMPL_WA}"
25SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_WA', 'OBMC_CHASSIS_INSTANCES')}"