Lei YU | e36b2af | 2018-04-11 11:10:31 +0800 | [diff] [blame] | 1 | SUMMARY = "Romulus ID Button pressed application" |
| 2 | PR = "r1" |
Patrick Venture | efd4c4f | 2018-11-05 20:07:35 -0800 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
Brad Bishop | cbbb0e5 | 2019-09-13 13:06:15 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Lei YU | e36b2af | 2018-04-11 11:10:31 +0800 | [diff] [blame] | 5 | |
| 6 | inherit obmc-phosphor-systemd |
Lei YU | e36b2af | 2018-04-11 11:10:31 +0800 | [diff] [blame] | 7 | |
| 8 | DEPENDS += "virtual/obmc-gpio-monitor" |
| 9 | RDEPENDS_${PN} += "virtual/obmc-gpio-monitor" |
| 10 | |
| 11 | S = "${WORKDIR}" |
| 12 | SRC_URI += "file://toggle_identify_led.sh" |
| 13 | |
| 14 | do_install() { |
| 15 | install -d ${D}${bindir} |
| 16 | install -m 0755 ${WORKDIR}/toggle_identify_led.sh \ |
| 17 | ${D}${bindir}/toggle_identify_led.sh |
| 18 | } |
| 19 | |
| 20 | SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/id_button" |
| 21 | |
| 22 | ID_BUTTON_SERVICE = "id_button" |
| 23 | |
| 24 | TMPL = "phosphor-gpio-monitor@.service" |
| 25 | INSTFMT = "phosphor-gpio-monitor@{0}.service" |
Patrick Venture | 85cff8c | 2019-04-04 13:06:43 -0700 | [diff] [blame] | 26 | TGT = "multi-user.target" |
Lei YU | e36b2af | 2018-04-11 11:10:31 +0800 | [diff] [blame] | 27 | FMT = "../${TMPL}:${TGT}.requires/${INSTFMT}" |
| 28 | |
| 29 | SYSTEMD_SERVICE_${PN} += "id-button-pressed.service" |
| 30 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'ID_BUTTON_SERVICE')}" |