blob: cebeefda61f4ff17f4ad57a5b91f918403317b5a [file] [log] [blame]
Matt Spinler17de1eb2017-06-06 09:40:45 -05001SUMMARY = "Witherspoon fan watchdog services"
2PR = "r1"
3
4inherit obmc-phosphor-license
5inherit obmc-phosphor-systemd
6
7RDEPENDS_${PN} += "phosphor-gpio-monitor"
8
9RESET_SERVICE = "witherspoon-reset-fan-watchdog.service"
10TGTFMT = "obmc-chassis-poweron@0.target"
11RESET_FMT = "../${RESET_SERVICE}:${TGTFMT}.requires/${RESET_SERVICE}"
12
13SYSTEMD_SERVICE_${PN} += "${RESET_SERVICE}"
14SYSTEMD_LINK_${PN} += "${RESET_FMT}"
15SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/witherspoon-fan-watchdog/witherspoon-reset-fan-watchdog.conf"