Brandon Wyman | 1c07875 | 2017-09-27 18:59:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Witherspoon Power Supply Sync" |
| 2 | DESCRIPTION = "Synchronizes the power supplies' INPUT_HISTORY data" |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit obmc-phosphor-license |
| 6 | inherit obmc-phosphor-systemd |
| 7 | |
| 8 | RDEPENDS_${PN} += "virtual/obmc-gpio-monitor" |
| 9 | |
| 10 | SYNC_SERVICE = "witherspoon-power-supply-sync.service" |
| 11 | TGTFMT = "obmc-chassis-poweron@0.target" |
| 12 | SYNC_FMT = "../${SYNC_SERVICE}:${TGTFMT}.wants/${SYNC_SERVICE}" |
| 13 | |
| 14 | SYSTEMD_SERVICE_${PN} += "${SYNC_SERVICE}" |
| 15 | SYSTEMD_LINK_${PN} += "${SYNC_FMT}" |