blob: 9c8a3dbd3c9ce0b1df02e685c25e1a8e3f339757 [file] [log] [blame]
Matt Spinler522fe002018-03-28 12:59:43 -05001SUMMARY = "IBM enhanced error logging"
2DESCRIPTION = "Adds additional error logging functionality for IBM systems"
3PR = "r1"
4HOMEPAGE = "https://github.com/openbmc/ibm-logging"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7SRC_URI += "git://github.com/openbmc/ibm-logging"
8SRCREV = "259e7277e6af53d2c4862cd48c14131c0b22bb81"
9
10inherit autotools
11inherit pkgconfig
12inherit obmc-phosphor-dbus-service
13inherit obmc-phosphor-systemd
14
15DEPENDS += " \
16 ibm-dbus-interfaces \
17 phosphor-logging \
18 nlohmann-json \
19 autoconf-archive-native \
20 sdbusplus \
21 "
22
23RDEPENDS_${PN} += " \
24 phosphor-logging \
25 phosphor-dbus-interfaces \
26 sdbusplus \
27 "
28
29S = "${WORKDIR}/git"
30
31SRC_URI += "file://policyTable.json"
32
33PACKAGECONFIG ??= ""
34PACKAGECONFIG[policy-interface] = "--enable-policy-interface, --disable-policy-interface,,"
35
36SERVICE = "com.ibm.Logging.service"
37DBUS_SERVICE_${PN} += "${SERVICE}"
38
39#The link is so that this service will restart if phosphor-logging restarts.
40#The BindsTo in the service will not do the restart, it will only do the
41#original start and a stop.
42LOG_FMT = "../${SERVICE}:xyz.openbmc_project.Logging.service.wants/${SERVICE}"
43SYSTEMD_LINK_${PN} += "${LOG_FMT}"
44
45do_install_append(){
46
47 install -d ${D}${datadir}/ibm-logging
48
49 ${S}/condense_policy.py \
50 -p ${WORKDIR}/policyTable.json \
51 -c ${D}/${datadir}/ibm-logging/policy.json
52}