blob: 947f5d7db4e73e91ad723f41ca60cf85ace5b3c3 [file] [log] [blame]
Matt Spinler456ff452018-03-26 16:23:38 -05001SUMMARY = "IBM DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the IBM YAML"
3PR = "r1"
4
5S = "${WORKDIR}/git"
6
7inherit autotools pkgconfig
8inherit obmc-phosphor-license
9inherit pythonnative
10inherit phosphor-dbus-yaml
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "sdbus++-native"
14
15SRC_URI += "git://github.com/openbmc/ibm-dbus-interfaces"
Andrew Geissler60c86d12018-05-23 16:45:03 -050016SRCREV = "62c7bff037587fe0fbfdffbe622058d86c7d7b7b"
Matt Spinler456ff452018-03-26 16:23:38 -050017
18DEPENDS_remove_class-native = "sdbus++-native"
19DEPENDS_remove_class-nativesdk = "sdbus++-native"
20
21PACKAGECONFIG ??= "libibm_dbus"
22PACKAGECONFIG[libibm_dbus] = " \
23 --enable-libibm_dbus, \
24 --disable-libibm_dbus, \
25 systemd sdbusplus, \
26 libsystemd sdbusplus \
27 "
28
29PACKAGECONFIG_remove_class-native = "libibm_dbus"
30PACKAGECONFIG_remove_class-nativesdk = "libibm_dbus"
31
32BBCLASSEXTEND += "native nativesdk"