Matt Spinler | 456ff45 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 1 | SUMMARY = "IBM DBus Interfaces" |
| 2 | DESCRIPTION = "Generated bindings, using sdbus++, for the IBM YAML" |
| 3 | PR = "r1" |
Patrick Venture | 36f7849 | 2018-10-17 15:10:55 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Matt Spinler | 456ff45 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 5 | |
| 6 | S = "${WORKDIR}/git" |
| 7 | |
| 8 | inherit autotools pkgconfig |
| 9 | inherit obmc-phosphor-license |
| 10 | inherit pythonnative |
| 11 | inherit phosphor-dbus-yaml |
| 12 | |
| 13 | DEPENDS += "autoconf-archive-native" |
| 14 | DEPENDS += "sdbus++-native" |
| 15 | |
| 16 | SRC_URI += "git://github.com/openbmc/ibm-dbus-interfaces" |
Andrew Geissler | ee85247 | 2018-10-04 21:30:14 +0000 | [diff] [blame] | 17 | SRCREV = "c9ae6bf297b40391256c8f21a01d72e049036017" |
Matt Spinler | 456ff45 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 18 | |
| 19 | DEPENDS_remove_class-native = "sdbus++-native" |
| 20 | DEPENDS_remove_class-nativesdk = "sdbus++-native" |
| 21 | |
| 22 | PACKAGECONFIG ??= "libibm_dbus" |
| 23 | PACKAGECONFIG[libibm_dbus] = " \ |
| 24 | --enable-libibm_dbus, \ |
| 25 | --disable-libibm_dbus, \ |
| 26 | systemd sdbusplus, \ |
| 27 | libsystemd sdbusplus \ |
| 28 | " |
| 29 | |
| 30 | PACKAGECONFIG_remove_class-native = "libibm_dbus" |
| 31 | PACKAGECONFIG_remove_class-nativesdk = "libibm_dbus" |
| 32 | |
| 33 | BBCLASSEXTEND += "native nativesdk" |