Matt Spinler | 456ff45 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 1 | SUMMARY = "IBM DBus Interfaces" |
| 2 | DESCRIPTION = "Generated bindings, using sdbus++, for the IBM YAML" |
| 3 | PR = "r1" |
Patrick Venture | 36f7849 | 2018-10-17 15:10:55 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Patrick Venture | 768df03 | 2018-11-03 08:36:39 -0700 | [diff] [blame] | 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Matt Spinler | 456ff45 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | |
| 10 | inherit autotools pkgconfig |
Matt Spinler | 456ff45 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 11 | inherit pythonnative |
| 12 | inherit phosphor-dbus-yaml |
| 13 | |
| 14 | DEPENDS += "autoconf-archive-native" |
| 15 | DEPENDS += "sdbus++-native" |
| 16 | |
| 17 | SRC_URI += "git://github.com/openbmc/ibm-dbus-interfaces" |
Andrew Geissler | 186199f | 2019-02-21 21:50:37 +0000 | [diff] [blame] | 18 | SRCREV = "109271bb4de159b9cf13c56acded3eb79bff61fb" |
Matt Spinler | 456ff45 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 19 | |
| 20 | DEPENDS_remove_class-native = "sdbus++-native" |
| 21 | DEPENDS_remove_class-nativesdk = "sdbus++-native" |
| 22 | |
| 23 | PACKAGECONFIG ??= "libibm_dbus" |
| 24 | PACKAGECONFIG[libibm_dbus] = " \ |
| 25 | --enable-libibm_dbus, \ |
| 26 | --disable-libibm_dbus, \ |
| 27 | systemd sdbusplus, \ |
| 28 | libsystemd sdbusplus \ |
| 29 | " |
| 30 | |
| 31 | PACKAGECONFIG_remove_class-native = "libibm_dbus" |
| 32 | PACKAGECONFIG_remove_class-nativesdk = "libibm_dbus" |
| 33 | |
| 34 | BBCLASSEXTEND += "native nativesdk" |