blob: 4fb9e2090d6e238e163561870a1fd795aca66cc4 [file] [log] [blame]
Lei YUb3cb3812016-12-22 16:15:03 +08001SUMMARY = "Romulus CPLD Trigger"
2DESCRIPTION = "Romulus power on workaround to trigger CPLD to continue power sequence"
3PR = "r0"
4
5inherit obmc-phosphor-systemd
6inherit obmc-phosphor-license
7
8RDEPENDS_${PN} += "obmc-pydevtools"
9
10PROVIDES += 'virtual/p9-vcs-workaround'
11RPROVIDES_${PN} += 'virtual-p9-vcs-workaround'
12
13S = "${WORKDIR}"
14SRC_URI += "file://cpld_trigger.sh"
15
16do_install() {
17 install -d ${D}${bindir}
18 install -m 0755 ${WORKDIR}/cpld_trigger.sh ${D}${bindir}/cpld_trigger.sh
19}
20
21TMPL = "cpld_trigger@.service"
22INSTFMT = "cpld_trigger@{0}.service"
23TGTFMT = "obmc-chassis-start@{0}.target"
24FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
25
26SYSTEMD_SERVICE_${PN} += "${TMPL}"
27SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
28