Matt Spinler | 456ff45 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 1 | SUMMARY = "IBM DBus Interfaces" |
| 2 | DESCRIPTION = "Generated bindings, using sdbus++, for the IBM YAML" |
| 3 | PR = "r1" |
| 4 | |
| 5 | S = "${WORKDIR}/git" |
| 6 | |
| 7 | inherit autotools pkgconfig |
| 8 | inherit obmc-phosphor-license |
| 9 | inherit pythonnative |
| 10 | inherit phosphor-dbus-yaml |
| 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
| 13 | DEPENDS += "sdbus++-native" |
| 14 | |
| 15 | SRC_URI += "git://github.com/openbmc/ibm-dbus-interfaces" |
Andrew Geissler | ee85247 | 2018-10-04 21:30:14 +0000 | [diff] [blame] | 16 | SRCREV = "c9ae6bf297b40391256c8f21a01d72e049036017" |
Matt Spinler | 456ff45 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 17 | |
| 18 | DEPENDS_remove_class-native = "sdbus++-native" |
| 19 | DEPENDS_remove_class-nativesdk = "sdbus++-native" |
| 20 | |
| 21 | PACKAGECONFIG ??= "libibm_dbus" |
| 22 | PACKAGECONFIG[libibm_dbus] = " \ |
| 23 | --enable-libibm_dbus, \ |
| 24 | --disable-libibm_dbus, \ |
| 25 | systemd sdbusplus, \ |
| 26 | libsystemd sdbusplus \ |
| 27 | " |
| 28 | |
| 29 | PACKAGECONFIG_remove_class-native = "libibm_dbus" |
| 30 | PACKAGECONFIG_remove_class-nativesdk = "libibm_dbus" |
| 31 | |
| 32 | BBCLASSEXTEND += "native nativesdk" |