blob: 891620b0c15a97bf8879e7fb2805d79e4acffc61 [file] [log] [blame]
Matt Spinler65ced222019-06-12 10:03:29 -05001SUMMARY = "Power device Workarounds"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
5
Brad Bishopd2cb8b62019-07-17 13:05:31 -04006inherit allarch
Matt Spinler65ced222019-06-12 10:03:29 -05007inherit obmc-phosphor-systemd
8
9RDEPENDS_${PN} += "i2c-tools"
10
11S = "${WORKDIR}"
12
13SRC_URI += "file://power-workarounds.sh"
14
15do_install() {
16 install -d ${D}${bindir}
17 install -m 0755 ${S}/power-workarounds.sh ${D}${bindir}/power-workarounds.sh
18}
19
20TMPL_WA = "power-workarounds@.service"
21INSTFMT_WA = "power-workarounds@{0}.service"
22TGTFMT = "obmc-chassis-poweron@{0}.target"
23FMT_WA = "../${TMPL_WA}:${TGTFMT}.requires/${INSTFMT_WA}"
24
25SYSTEMD_SERVICE_${PN} += "${TMPL_WA}"
26SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_WA', 'OBMC_CHASSIS_INSTANCES')}"