Lei YU | e020d0d | 2019-05-23 16:44:39 +0800 | [diff] [blame] | 1 | SUMMARY = "Romulus BMC accesible FRU inventory map for phosphor-ipmi-host" |
| 2 | PR = "r1" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
| 5 | |
| 6 | inherit native |
| 7 | inherit phosphor-ipmi-host |
| 8 | |
| 9 | SRC_URI += "file://bmc-fru-config.yaml" |
| 10 | |
| 11 | S = "${WORKDIR}" |
| 12 | |
| 13 | PROVIDES += "virtual/phosphor-ipmi-fru-read-bmc-inventory" |
| 14 | |
| 15 | do_install_append() { |
| 16 | DEST=${D}${config_datadir} |
| 17 | install -d ${DEST} |
| 18 | install bmc-fru-config.yaml ${DEST}/bmc-fru-config.yaml |
| 19 | } |