blob: 73c8282246271b6e4bfd312f0fe013991ceef8aa [file] [log] [blame]
Lei YUaaad5a52016-12-27 14:43:14 +08001SUMMARY = "Romulus VRM Overrides"
2DESCRIPTION = "Sets Rolumus VRMs to custom voltages"
3PR = "r1"
4
5inherit obmc-phosphor-systemd
6inherit obmc-phosphor-license
7
8RDEPENDS_${PN} += "i2c-tools bash"
9
10S = "${WORKDIR}"
Lei YU574034e2017-01-05 11:15:47 +080011SRC_URI += "file://vrm-control.sh \
12 file://vrm.sh"
Lei YUaaad5a52016-12-27 14:43:14 +080013
14do_install() {
15 install -d ${D}${bindir}
Lei YU574034e2017-01-05 11:15:47 +080016 install -m 0755 ${WORKDIR}/vrm.sh ${D}${bindir}/vrm.sh
Lei YUaaad5a52016-12-27 14:43:14 +080017 install -m 0755 ${WORKDIR}/vrm-control.sh ${D}${bindir}/vrm-control.sh
18}
19
20TMPL = "vrm-control@.service"
21INSTFMT = "vrm-control@{0}.service"
Lei YUd43ec212017-02-14 16:47:45 +080022TGTFMT = "obmc-power-chassis-on@{0}.target"
Lei YUf2e12312017-02-20 10:22:27 +080023FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
Lei YUaaad5a52016-12-27 14:43:14 +080024
25SYSTEMD_SERVICE_${PN} += "${TMPL}"
26SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"