Matt Spinler | c103747 | 2016-12-20 09:28:21 -0600 | [diff] [blame] | 1 | SUMMARY = "Witherspoon VRM Overrides" |
| 2 | DESCRIPTION = "Sets Witherspoon VRMs to custom voltages" |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit obmc-phosphor-systemd |
| 6 | inherit obmc-phosphor-license |
| 7 | |
| 8 | RDEPENDS_${PN} += "i2c-tools bash" |
| 9 | |
| 10 | S = "${WORKDIR}" |
| 11 | SRC_URI += "file://vrm-control.sh" |
| 12 | |
| 13 | do_install() { |
| 14 | install -d ${D}${bindir} |
| 15 | install -m 0755 ${WORKDIR}/vrm-control.sh ${D}${bindir}/vrm-control.sh |
| 16 | } |
| 17 | |
| 18 | TMPL = "vrm-control@.service" |
| 19 | INSTFMT = "vrm-control@{0}.service" |
| 20 | TGTFMT = "obmc-chassis-start@{0}.target" |
| 21 | FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}" |
| 22 | |
| 23 | SYSTEMD_SERVICE_${PN} += "${TMPL}" |
| 24 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}" |