blob: 76fb67dc35e09a99cc163be28d4d3f876c2b8c99 [file] [log] [blame]
Yong Lic5a33a92019-01-03 11:41:48 +08001SUMMARY = "Intel DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the Intel YAML"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7
8S = "${WORKDIR}/git"
9
10inherit autotools pkgconfig
11inherit pythonnative
12inherit phosphor-dbus-yaml
13
14DEPENDS += "autoconf-archive-native"
15DEPENDS += "sdbus++-native"
16
17SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces"
Andrew Geissler06cb7872019-06-10 01:00:56 +000018SRCREV = "b5f2dd444c5d3808d005452417e4ae2ea28624ff"
Yong Lic5a33a92019-01-03 11:41:48 +080019
20DEPENDS_remove_class-native = "sdbus++-native"
21DEPENDS_remove_class-nativesdk = "sdbus++-native"
22
23PACKAGECONFIG ??= "libintel_dbus"
24PACKAGECONFIG[libintel_dbus] = " \
25 --enable-libintel_dbus, \
26 --disable-libintel_dbus, \
27 systemd sdbusplus, \
28 libsystemd sdbusplus \
29 "
30
31PACKAGECONFIG_remove_class-native = "libintel_dbus"
32PACKAGECONFIG_remove_class-nativesdk = "libintel_dbus"
33
34BBCLASSEXTEND += "native nativesdk"