Jason M. Bills | 8c20b5f | 2018-10-05 09:17:31 -0700 | [diff] [blame] | 1 | SUMMARY = "Intel OEM IPMI commands" |
| 2 | DESCRIPTION = "Intel OEM IPMI commands" |
| 3 | |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a6a4edad4aed50f39a66d098d74b265b" |
| 6 | |
| 7 | SRC_URI = "git://github.com/openbmc/intel-ipmi-oem" |
| 8 | SRCREV = "6479604111b8198592c1054a3bad751f3b80a689" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | PV = "0.1+git${SRCPV}" |
| 12 | |
| 13 | DEPENDS = "boost phosphor-ipmi-host systemd microsoft-gsl" |
| 14 | |
| 15 | inherit cmake obmc-phosphor-ipmiprovider-symlink |
| 16 | |
| 17 | EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1" |
| 18 | |
| 19 | LIBRARY_NAMES = "libsensorcommands.so" |
| 20 | LIBRARY_NAMES += "libzstoragecommands.so" |
| 21 | LIBRARY_NAMES += "liboemcmds.so" |
| 22 | |
| 23 | HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}" |
| 24 | NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}" |
| 25 | |
| 26 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 27 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 28 | FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 29 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}" |