Yong Li | c5a33a9 | 2019-01-03 11:41:48 +0800 | [diff] [blame] | 1 | SUMMARY = "Intel DBus Interfaces" |
| 2 | DESCRIPTION = "Generated bindings, using sdbus++, for the Intel YAML" |
| 3 | PR = "r1" |
| 4 | PV = "1.0+git${SRCPV}" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | |
| 10 | inherit autotools pkgconfig |
| 11 | inherit pythonnative |
| 12 | inherit phosphor-dbus-yaml |
| 13 | |
| 14 | DEPENDS += "autoconf-archive-native" |
| 15 | DEPENDS += "sdbus++-native" |
| 16 | |
| 17 | SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces" |
Andrew Geissler | 8bd18e7 | 2019-02-15 21:10:50 +0000 | [diff] [blame] | 18 | SRCREV = "2b8f89f5876c5a97a34cdf922729d4283d5f2627" |
Yong Li | c5a33a9 | 2019-01-03 11:41:48 +0800 | [diff] [blame] | 19 | |
| 20 | DEPENDS_remove_class-native = "sdbus++-native" |
| 21 | DEPENDS_remove_class-nativesdk = "sdbus++-native" |
| 22 | |
| 23 | PACKAGECONFIG ??= "libintel_dbus" |
| 24 | PACKAGECONFIG[libintel_dbus] = " \ |
| 25 | --enable-libintel_dbus, \ |
| 26 | --disable-libintel_dbus, \ |
| 27 | systemd sdbusplus, \ |
| 28 | libsystemd sdbusplus \ |
| 29 | " |
| 30 | |
| 31 | PACKAGECONFIG_remove_class-native = "libintel_dbus" |
| 32 | PACKAGECONFIG_remove_class-nativesdk = "libintel_dbus" |
| 33 | |
| 34 | BBCLASSEXTEND += "native nativesdk" |