blob: cdb88bbfe2c2ad797721404145ae448e090bc211 [file] [log] [blame]
Yong Lic5a33a92019-01-03 11:41:48 +08001SUMMARY = "Intel DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the Intel YAML"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7
8S = "${WORKDIR}/git"
9
10inherit autotools pkgconfig
Patrick Williamse7eeb882020-03-31 16:43:15 -050011inherit python3native
Yong Lic5a33a92019-01-03 11:41:48 +080012inherit phosphor-dbus-yaml
13
14DEPENDS += "autoconf-archive-native"
Patrick Williamse7eeb882020-03-31 16:43:15 -050015DEPENDS += "${PYTHON_PN}-sdbus++-native"
Yong Lic5a33a92019-01-03 11:41:48 +080016
17SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces"
Andrew Geissler06cb7872019-06-10 01:00:56 +000018SRCREV = "b5f2dd444c5d3808d005452417e4ae2ea28624ff"
Yong Lic5a33a92019-01-03 11:41:48 +080019
Yong Lic5a33a92019-01-03 11:41:48 +080020PACKAGECONFIG ??= "libintel_dbus"
21PACKAGECONFIG[libintel_dbus] = " \
22 --enable-libintel_dbus, \
23 --disable-libintel_dbus, \
24 systemd sdbusplus, \
Patrick Williamse7eeb882020-03-31 16:43:15 -050025 libsystemd \
Yong Lic5a33a92019-01-03 11:41:48 +080026 "
27
28PACKAGECONFIG_remove_class-native = "libintel_dbus"
29PACKAGECONFIG_remove_class-nativesdk = "libintel_dbus"
30
Patrick Williamse7eeb882020-03-31 16:43:15 -050031BBCLASSEXTEND += "native nativesdk"