blob: cefdea803c7bc07689546205f17aaf667b2afb25 [file] [log] [blame]
Tomer Maimon757eeed2018-01-29 17:36:16 +02001SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
4SECTION = "bootloader"
5DEPENDS = "mtd-utils"
6
7PROVIDES += "u-boot-fw-utils"
8
9UBRANCH = "npcm7xx"
10SRC_URI = "git://github.com/Nuvoton-Israel/u-boot.git;branch=${UBRANCH}"
11SRCREV = "196461383f7d043f18cab3bb34dded89fba4712a"
12
13PV .= "+${UBRANCH}+"
14
15S = "${WORKDIR}/git"
16
17INSANE_SKIP_${PN} = "already-stripped"
18
19EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" HOSTCC="${BUILD_CC} ${BUILD_FLAGS} ${BUILD_LDFLAGS}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
20EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
21
22inherit uboot-config
23
24do_compile () {
25 oe_runmake ${UBOOT_MACHINE}
26 oe_runmake env
27}
28
29do_install () {
30 install -d ${D}${base_sbindir}
31 install -d ${D}${sysconfdir}
32 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
33 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
34 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
35}
36
37do_install_class-cross () {
38 install -d ${D}${bindir_cross}
39 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
40 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
41}
42
43SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
44uboot_fw_utils_cross() {
45 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
46}
47
48PACKAGE_ARCH = "${MACHINE_ARCH}"
49BBCLASSEXTEND = "cross"