blob: 7cfbce345794f1b1ff7ef73add824c66c2c04c3f [file] [log] [blame]
SUMMARY = "Open POWER DBus Interfaces"
DESCRIPTION = "Generated bindings, using sdbus++, for the openpower YAML"
PR = "r1"
S = "${WORKDIR}/git"
inherit autotools pkgconfig
inherit obmc-phosphor-license
inherit pythonnative
DEPENDS += "autoconf-archive-native"
DEPENDS += "sdbus++-native"
PACKAGE_BEFORE_PN = "${PN}-yaml"
FILES_${PN}-yaml = "${datadir}/${PN}/yaml"
SRC_URI += "git://github.com/openbmc/openpower-dbus-interfaces"
SRCREV = "b331f56c416812b20c1a338b3ffdce32d169a0c1"
DEPENDS_remove_class-native = "sdbus++-native"
DEPENDS_remove_class-nativesdk = "sdbus++-native"
PACKAGECONFIG ??= "libopenpower_dbus"
PACKAGECONFIG[libopenpower_dbus] = " \
--enable-libopenpower_dbus, \
--disable-libopenpower_dbus, \
systemd sdbusplus, \
libsystemd sdbusplus \
"
PACKAGECONFIG_remove_class-native = "libopenpower_dbus"
PACKAGECONFIG_remove_class-nativesdk = "libopenpower_dbus"
BBCLASSEXTEND += "native nativesdk"