Vishwanatha Subbanna | 11631c7 | 2017-08-09 15:00:34 +0530 | [diff] [blame^] | 1 | SUMMARY = "OpenPower OCC Control with MRW generated sensor IDs" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit native |
| 5 | inherit obmc-phosphor-utils |
| 6 | inherit obmc-phosphor-license |
| 7 | inherit openpower-occ-control |
| 8 | |
| 9 | PROVIDES += "virtual/openpower-occ-control-config-native" |
| 10 | DEPENDS += "mrw-native mrw-perl-tools-native" |
| 11 | |
| 12 | # Generate a YAML files based on MRW input |
| 13 | do_install_append() { |
| 14 | install -d ${YAML_DEST}/ |
| 15 | ${STAGING_BINDIR_NATIVE}/perl-native/perl \ |
| 16 | ${STAGING_BINDIR_NATIVE}/gen_occ_map.pl \ |
| 17 | -i ${STAGING_DATADIR_NATIVE}/obmc-mrw/${MACHINE}.xml \ |
| 18 | -o ${YAML_DEST}/occ_sensor.yaml |
| 19 | } |