blob: 2511e45d243c01c9b817d44660705bedaafd3a7f [file] [log] [blame]
Edward A. Jamesdc428cf2017-02-14 17:10:10 -06001SUMMARY = "I2C debug tool"
2DESCRIPTION = "iicmaster provides a debug interface for remote, FSI-based I2C engines"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
5
6SRC_URI += "git://github.com/eddiejames/iicmaster.git"
7
8SRCREV = "b71dbf99af495a631dc5f3564296903667bc516c"
9PV = "git${SRCREV}"
10
11S = "${WORKDIR}/git"
12
13do_install() {
14 install -d ${D}${bindir}
15 install -m 0755 iicmaster ${D}${bindir}
16}
Saqib Khanfd2bc342017-03-10 11:26:09 -060017
18#TODO: openbmc/openbmc#1362 - Fix GNU_HASH warnings in iic2master
19TARGET_CC_ARCH += "${LDFLAGS}"