Sergey Solomin | 67305e3 | 2016-11-28 15:03:24 -0600 | [diff] [blame] | 1 | SUMMARY = "POWER9 VCS workaround" |
| 2 | DESCRIPTION = "Apply fixes over FSI to POWER9 CPUs prior to host power on" |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit obmc-phosphor-systemd |
| 6 | inherit obmc-phosphor-license |
| 7 | |
| 8 | FILESEXTRAPATHS_prepend := "${THISDIR}/op-pdbg-host-control:" |
| 9 | |
| 10 | RDEPENDS_${PN} += "pdbg \ |
| 11 | virtual-p9-vcs-workaround" |
| 12 | |
| 13 | S = "${WORKDIR}" |
| 14 | SRC_URI += "file://vcs_workaround.sh" |
| 15 | |
| 16 | do_install() { |
| 17 | install -d ${D}${bindir} |
| 18 | install -m 0755 ${WORKDIR}/vcs_workaround.sh \ |
| 19 | ${D}${bindir}/vcs_workaround.sh |
| 20 | } |
| 21 | |
| 22 | TMPL = "vcs_workaround@.service" |
| 23 | INSTFMT = "vcs_workaround@{0}.service" |
Andrew Geissler | f7cff86 | 2017-01-30 12:42:40 -0600 | [diff] [blame] | 24 | TGTFMT = "obmc-power-chassis-on@{0}.target" |
Sergey Solomin | 67305e3 | 2016-11-28 15:03:24 -0600 | [diff] [blame] | 25 | FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}" |
| 26 | |
| 27 | SYSTEMD_SERVICE_${PN} += "${TMPL}" |
| 28 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}" |
| 29 | SYSTEMD_SUBSTITUTIONS += "MACHINE:${MACHINE}:${TMPL}" |