Sergey Solomin | 67305e3 | 2016-11-28 15:03:24 -0600 | [diff] [blame^] | 1 | SUMMARY = "POWER9 start host" |
| 2 | DESCRIPTION = "Service to start POWER9 IPL through SBE" |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit obmc-phosphor-systemd |
| 6 | inherit obmc-phosphor-license |
| 7 | |
| 8 | FILESEXTRAPATHS_prepend := "${THISDIR}/op-pdbg-host-control:" |
| 9 | |
| 10 | PROVIDES += 'virtual/obmc-host-ctl' |
| 11 | RPROVIDES_${PN} += 'virtual-obmc-host-ctl' |
| 12 | |
| 13 | RDEPENDS_${PN} += "pdbg \ |
| 14 | p9-vcs-workaround" |
| 15 | |
| 16 | S = "${WORKDIR}" |
| 17 | SRC_URI += "file://start_host.sh" |
| 18 | |
| 19 | do_install() { |
| 20 | install -d ${D}${bindir} |
| 21 | install -m 0755 ${WORKDIR}/start_host.sh \ |
| 22 | ${D}${bindir}/start_host.sh |
| 23 | } |
| 24 | |
| 25 | TMPL = "start_host@.service" |
| 26 | INSTFMT = "start_host@{0}.service" |
| 27 | TGTFMT = "obmc-chassis-start@{0}.target" |
| 28 | FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}" |
| 29 | |
| 30 | SYSTEMD_SERVICE_${PN} += "${TMPL}" |
| 31 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}" |
| 32 | SYSTEMD_SUBSTITUTIONS += "MACHINE:${MACHINE}:${TMPL}" |