blob: ec4d429396e80ca8de4471944977434662d0c701 [file] [log] [blame]
Marri Devender Rao6a48c3c2017-04-27 03:38:39 -05001SUMMARY = "OpenPOWER Debug Collector"
2DESCRIPTION = "Application to log error during host checkstop"
3
4PR = "r1"
5
6inherit autotools \
7 pkgconfig \
8 obmc-phosphor-systemd \
9
10require ${PN}.inc
11
12DEPENDS += " \
13 phosphor-logging \
14 autoconf-archive-native \
15 "
16
17RDEPENDS_${PN} += " \
18 phosphor-logging \
19 "
20
21S = "${WORKDIR}/git"
22
23TMPL = "openpower-debug-collector@.service"
24INSTFMT = "openpower-debug-collector@{0}.service"
25LINK_FMT = "${TMPL}:${INSTFMT}"
26
27SYSTEMD_SERVICE_${PN} += "${TMPL}"
28SYSTEMD_LINK_${PN} += "${@compose_list(d, 'LINK_FMT', 'OBMC_CHECKSTOP_INSTANCES')}"