blob: bab0b63faeda91972fcfa6998eff6ad4be6f3596 [file] [log] [blame]
Brad Bishop43483152016-04-15 09:53:23 -04001SUMMARY = "Inventory upload"
2DESCRIPTION = "Inventory upload."
3HOMEPAGE = "http://github.com/openbmc/openpower-inventory-upload"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7
8inherit allarch
9inherit setuptools
Brad Bishopc397df72016-08-17 20:27:37 -040010inherit obmc-phosphor-systemd
Brad Bishop43483152016-04-15 09:53:23 -040011
12RDEPENDS_${PN} += " \
Brad Bishop6a9c9082016-05-03 10:51:48 -040013 python-dbus \
14 python-pygobject \
Brad Bishop43483152016-04-15 09:53:23 -040015 pyphosphor \
16 dtc \
17 "
18
19SRC_URI += "git://github.com/openbmc/openpower-inventory-upload"
20
Adriana Kobylak30633da2016-06-09 16:29:45 -050021SRCREV = "b07de872ac18710dbf0d393a206e2598c6580f46"
Brad Bishop43483152016-04-15 09:53:23 -040022
23S = "${WORKDIR}/git"
Brad Bishopc397df72016-08-17 20:27:37 -040024
25TMPL = "op-inventory-upload@.service"
26INSTFMT = "op-inventory-upload@{0}.service"
Josh D. Kingd15112e2017-04-06 15:56:37 -050027TGTFMT = "obmc-host-start@{0}.target"
Brad Bishopc397df72016-08-17 20:27:37 -040028FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
29
30SYSTEMD_SERVICE_${PN} += "${TMPL}"
31SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"