Marri Devender Rao | 28ad34e | 2019-09-25 03:19:29 -0500 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
| 2 | SRC_URI += "file://plugins.d/guard" |
| 3 | |
| 4 | install_openpower_plugins() { |
| 5 | install -m 0755 ${WORKDIR}/plugins.d/guard ${D}${dreport_plugin_dir} |
| 6 | } |
| 7 | |
| 8 | #Link in the plugins so dreport run them at the appropriate time |
| 9 | python link_openpower_plugins() { |
| 10 | workdir = d.getVar('WORKDIR', True) |
| 11 | script = os.path.join(workdir, 'plugins.d', 'guard') |
| 12 | install_dreport_user_script(script, d) |
| 13 | } |
| 14 | |
| 15 | DEBUG_COLLECTOR_INSTALL_POSTFUNCS ?= "" |
| 16 | DEBUG_COLLECTOR_INSTALL_POSTFUNCS_df-openpower ?= "install_openpower_plugins link_openpower_plugins" |
| 17 | |
| 18 | do_install[postfuncs] += "${DEBUG_COLLECTOR_INSTALL_POSTFUNCS}" |