blob: 67e07340eabeeaa533a731782186c2854b3d358f [file] [log] [blame]
Deepak Kodihalli52bcaed2017-03-17 03:51:13 -05001SUMMARY = "Open POWER DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the openpower YAML"
3PR = "r1"
Patrick Venture542d1f72018-10-02 19:51:03 -07004PV = "1.0+git${SRCPV}"
Deepak Kodihalli52bcaed2017-03-17 03:51:13 -05005
6S = "${WORKDIR}/git"
7
8inherit autotools pkgconfig
9inherit obmc-phosphor-license
10inherit pythonnative
Marri Devender Rao9f9431d2017-05-29 01:33:26 -050011inherit phosphor-dbus-yaml
Deepak Kodihalli52bcaed2017-03-17 03:51:13 -050012
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "sdbus++-native"
15
Deepak Kodihalli52bcaed2017-03-17 03:51:13 -050016SRC_URI += "git://github.com/openbmc/openpower-dbus-interfaces"
Andrew Geisslerbd37e482018-10-05 01:30:11 +000017SRCREV = "998a82ec587be23bc5c2e59ba858fb099279c5f0"
Deepak Kodihalli52bcaed2017-03-17 03:51:13 -050018
19DEPENDS_remove_class-native = "sdbus++-native"
20DEPENDS_remove_class-nativesdk = "sdbus++-native"
21
22PACKAGECONFIG ??= "libopenpower_dbus"
23PACKAGECONFIG[libopenpower_dbus] = " \
24 --enable-libopenpower_dbus, \
25 --disable-libopenpower_dbus, \
26 systemd sdbusplus, \
27 libsystemd sdbusplus \
28 "
29
30PACKAGECONFIG_remove_class-native = "libopenpower_dbus"
31PACKAGECONFIG_remove_class-nativesdk = "libopenpower_dbus"
32
33BBCLASSEXTEND += "native nativesdk"