Adriana Kobylak | adb57d9 | 2017-04-28 16:05:39 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenPower Software Management" |
| 2 | DESCRIPTION = "OpenPower Software Manager provides a set of host software \ |
| 3 | management daemons. It is suitable for use on a wide variety of OpenPower \ |
| 4 | platforms." |
| 5 | HOMEPAGE = "https://github.com/openbmc/openpower-pnor-code-mgmt" |
| 6 | PR = "r1" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 9 | |
| 10 | inherit autotools pkgconfig |
| 11 | inherit obmc-phosphor-dbus-service |
| 12 | |
| 13 | DEPENDS += " \ |
| 14 | autoconf-archive-native \ |
| 15 | phosphor-dbus-interfaces \ |
| 16 | phosphor-logging \ |
| 17 | sdbusplus \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS_${PN} += " \ |
| 21 | mtd-utils-ubifs \ |
| 22 | phosphor-dbus-interfaces \ |
| 23 | phosphor-logging \ |
| 24 | sdbusplus \ |
| 25 | " |
| 26 | |
Adriana Kobylak | fc00de8 | 2017-06-02 09:22:40 -0500 | [diff] [blame] | 27 | S = "${WORKDIR}/git" |
| 28 | |
| 29 | SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt" |
| 30 | |
Adriana Kobylak | 5bd157c | 2017-05-25 15:48:27 -0500 | [diff] [blame] | 31 | SRC_URI += " \ |
| 32 | file://bios-ubiattach \ |
| 33 | file://bios-ubiformat" |
| 34 | |
Patrick Williams | 085be70 | 2017-06-14 02:40:03 -0500 | [diff] [blame] | 35 | SRCREV = "2021b4ced699601a82eb716ffcdf29e0fa949a6d" |
Adriana Kobylak | fc00de8 | 2017-06-02 09:22:40 -0500 | [diff] [blame] | 36 | |
| 37 | do_install_append() { |
Adriana Kobylak | 5bd157c | 2017-05-25 15:48:27 -0500 | [diff] [blame] | 38 | install -d ${D}${sbindir} |
| 39 | install -m 0755 ${WORKDIR}/bios-ubiattach ${D}${sbindir}/bios-ubiattach |
| 40 | install -m 0755 ${WORKDIR}/bios-ubiformat ${D}${sbindir}/bios-ubiformat |
| 41 | } |
| 42 | |
Adriana Kobylak | adb57d9 | 2017-04-28 16:05:39 -0500 | [diff] [blame] | 43 | DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service" |
Adriana Kobylak | fc00de8 | 2017-06-02 09:22:40 -0500 | [diff] [blame] | 44 | |
Adriana Kobylak | adb57d9 | 2017-04-28 16:05:39 -0500 | [diff] [blame] | 45 | SYSTEMD_SERVICE_${PN} += " \ |
| 46 | obmc-flash-bios-ubiattach.service \ |
| 47 | obmc-flash-bios-ubimount@.service \ |
Adriana Kobylak | e68378f | 2017-05-22 14:41:02 -0500 | [diff] [blame] | 48 | obmc-flash-bios-ubiumount-prsv.service \ |
| 49 | obmc-flash-bios-ubiumount-rw@.service \ |
Adriana Kobylak | adb57d9 | 2017-04-28 16:05:39 -0500 | [diff] [blame] | 50 | obmc-flash-bios-squashfsmount@.service \ |
| 51 | " |